Annonce

Réduire
Aucune annonce.

SAV pour Factory Complex Constructor V3.21 par Dusty [KBG]

Réduire
X
  • Filtre
  • Heure
  • Afficher
Tout nettoyer
nouveaux messages

    SAV pour Factory Complex Constructor V3.21 par Dusty [KBG]

    • Topic dédié au retour d'information des joueurs et support.


    Soyez clair et précis dans votre description svp.

    Merci :)

    #2
    Factory Complex Constructor V3.21

    Auteur : Dusty [KBG]


    Un fantastique script de construction facilitée de complexes parfaitement alignés, et possibilté de construction hors secteur ! Possibilité de déplacer des complexes entiers, avertissement de risque de collisions de stations lors de l'assemblage et réalignement de stations déja existantes.


    Construire un complexe est une tâche délicate. Diverses contraintes font de cette tâche quelque chose de plutôt compliquée.
    Par exemple, la carte du secteur (bien que translucide) gène la vue pendant le positionnement de la station.

    Même avec une haute résolution (disons 1600 x 1200), la visibilité est faible.
    La carte du secteur empêche une vue directe, et ce n’est pas le seul problème. Il est difficile de faire pivoter une station ou d’en aligner plusieurs. Une partie du problème vient du fait que le mouvement est continu et non par étapes.
    Le fait de ne pas pouvoir déplacer une station une fois celle-ci connectée à un complexe ne simplifie pas la tâche...

    Les stations ont des tailles, des formes et des emplacements de nœuds de connexion différents. Aligner de tels objets différents exige souvent des rajustements dans la position et l'orientation.
    En plus les stations sont translucides durant le processus de placement ce qui rend difficile de voir les points de connexion (nœuds).
    De fait on les place juste grossièrement à l’endroit désiré et on les connecte. Le résultat est bien connu des joueurs de X3: un complexe bizarre avec des tubes en zigzag.
    Le script Factory Complex Constructor a été développé pour permettre la construction de complexes avec la présentation souhaitée.
    Les complexes ne sont pas seulement plus jolis, ils sont aussi moins gourmands en ressource machine car ils n’occupent pas tout le secteur et les vaisseaux non joueur (avec le QI d’une tranche de toast) ne sont plus coincés dans les tubes de la construction.

    Le script Factory Complex Constructor propose les Fonctions Principales suivantes:

     Construction de station et de complexe
     Positionnement/rotation précis pour des complexes compacts (Précision: jusqu’à 25m / 7,5°)
     Construction de station hors du secteur
     Positionnement d’une usine dans un complexe
     Construction d’un unique module principal (Aucun alignement au nord!)
     Pas d’obstruction de la vue lors de la construction de stations! (Carte du secteur, etc.)
     Réagencement des stations déjà construites
     Avertissement des risques de collision des stations
     Déplacement de complexe entier


    Le PlugIn supporte toutes les stations et usines disponible dans la version „vanilla“ du jeu et les stations qui ont été rajoutées à X3 avec modification.
    Les docks d’équipement, chantiers navals et stations commerciales sont aussi gérés, mais ne peuvent pas être intégrés dans un complexe.
    Liens :


    Manuel de l'utilisateur très complet et illustré en FR

    Topic sur le forum officiel en anglais - le hosting est assuré par l'auteur

    FCC-Plugin pour le script "Ashley's Factories" - le hosting est assuré par l'auteur

    RAR complet avec le fichier d'installation .spk et le manuel - le hosting est assuré par l'auteur

    ----------------------------------------------------------------------------------
    Dernière modification par phlt, 28-04-10, 08h06.

    Commentaire


      #3
      FCC

      Salut phlt

      Je suis sous le MOD XTM et je sais pas si je suis plus quiche que les autres mais je ne comprend pas comment marche ce script je l'ai installer je pense correctement vu que c'est automatique(sans le XScript Installer), j'ai activer le script avec Thereshallbewings je me suis acheter un TL avec un rayon tracteur des stations et des kits de raccordement en soute mais je ne trouve rien dans le panneaux de commandes, ni général ni special et je ne reçois pas de confirmation sonore de bonne installation de script...ça fait 3 jours que j'essaye de l'installer et toujours rien j'ai été sur les forum ou ont en parle mais je ne trouve pas la solution et franchement je commence à criser, alors si tu as un conseil je suis super preneur, merci d'avance.

      Commentaire


        #4
        As-tu programmé les touches de fonctions du script comme indiqué dans le manuel d'utilisateur...
        Liens pour le mode d'emplois en français ci-dessous!!!
        http://www.3enfamille.net/vb/showthread.php?t=253
        Dans le menu principal /options/ il faut régler les touches pour faire fonctionner le script page 6/23(configuration des raccourcis Chap 2.2)
        Je te conseille vraiment la lecture du manuel!!
        La page 5/23 (Setup & Installation) explique l'installation sans passer par le Theres..... installe si tu ne l'a pas le Xplugin Manager de Cycrow..
        http://www.3enfamille.net/vb/showthread.php?t=67
        Il te serras utile , il fait tout automatiquement et fonctionne très bien..et est très simple d'emplois.
        Il installe et dés-installe facilement les scripts et permet de vérifier les conflits entre plusieurs scripts .
        Pour l'utilisation je te conseille d'être à bord du TL et avec la fonction "Spécial " Implanter station ici tu positionne ta station et ajoute les autres stations au fur et à mesure...
        Au cas de soucis n'hésite pas.....
        Cpt-Killer NH's BREIZH TEAM ..

        Commentaire


          #5
          Chris la nouille ( le retour ! )

          Salut Cpt-Killer

          Meci pour ta réponse rapide mais je pense qu'il y a un blème que je localise pas,je récapitule ...tu me confirmes si je fais pas la nouille (c'est pas jouer...)

          1 - le script que je télécharge est un .exe....soit... je le recharge en .rar...ok
          2 - J'ai aussi Xplugin Manager de Cycrow mais il ne voit pas ce script au contraire de tous les autres
          3 - Je vérifie alors dans le dossier "script et t "du jeux si les fichiers sont présent...c'est ok aussi il sont bien là
          4 - Le readme je l'ai usée à force de le lire, mais quand je vais dans le panneau de controle pour le paramétrage d'installation de station je ne trouve que les 4 commandes de base pour bouger la station en mode normal quoi...je commence à devenir chèvre
          5 - Par acquis de conscience je vérifie dans le gameplay pour voir si le script y est....et bien non il y est pas...alors que tout les autres script y sont .

          Moi ce que je trouve pas vraiment clair c'est pourquoi Xplugin Manager ne vois pas ce script alors que j'ai l'impréssion que tout le monde a installer ce script par sont intermédiaire...? Pfffffffff je rame !

          Commentaire


            #6
            Je vérifie comment je l'ai installé , le paramétrage des touches , et également à propos du script Manager car je crois que l'on peut l'installer avec , je jette un oeil aussi sur l'activation du script et te donne des nouvelles rapidement!! :-)
            A moins que quelqu'un te donne une réponse d'ici là !! je perd pas espoir ...tout va s'arranger
            Cpt-Killer NH's BREIZH TEAM ..

            Commentaire


              #7
              Bon après quelques vérification me voici de retour..
              1)Factory Complex Constructor (FCC) est bien installable via X Plugging Manager . la version pck est disponible avec le fichier telechargeable.
              2)Sinon après décompression du fichier .rar tu copies tout les fichiers de "Scripts" dans "script d'X3" et tout les fichiers .xml de "t "dans "t "d'X3.
              ça je pense que tu le faisais déjà...
              3)lancement du jeu ; un message plugin doit te remercier d'avoir installer FCC.
              4)Aller dans : Menu principal / Options / Contrôles / Interfaces.
              il faut programmer les touches de contrôles de FCC (en bleu clair !) tout en bas de la liste ; perso idem que sur la page6/23 du readme ..
              5)Normalement l'on retrouve les commandes quand on pilote son TL...et là je suis désolé , je viens de relancer une partie , et je n'ai pas encore de TL , ni de station à installer. Je n'avais juste commencer à me servir du FCC avant cette nouvelle relance du jeu donc je ne pourrais pas être d'une grande aide sur le maniement des touches !
              Ps: n'oublie pas d'avoir un rayon tracteur dans ton vaisseau ou dans autre vaisseau présent dans le secteur...
              J'espère t'avoir un peu aider , sinon n'hésite pas à demander..:-)
              Cpt-Killer NH's BREIZH TEAM ..

              Commentaire


                #8
                chris

                Ca marche pas.... tout ce que tu dis je l'ais fait et je me demande si ça ne viens pas de ma bécane mais je ne vois pas pourquoi....quand j'installe les fichier RAR à leurs places respective dans "script" et "t" il ne ce passe absolument rien au démarrage du jeux et dans le panneau de l'interface il n'y a rien non plus ...je crise...je viens de voir ton message privé et je te contact via ma boite mail.

                Commentaire


                  #9
                  Problème d'install de scripts FCC

                  Enfin !!! j'ai réussi à installer ce script mais pas de la façon habituelle,
                  D'habitude je passe par " XScript Installer " et parfois cela me donne comme message "Unable to open script package " je déteste cordialement ce message..... et je l'ai eu pendant 3 jours pour installer FCC.....
                  Pour régler ce problème rendez vous dans le répertoire ou vous stockez vos scripts faite un clic droit sur le l'icône du script qui vous intéresse vous aurez alors une fenêtre avec :

                  Install Package
                  Explore Package
                  Extract

                  Vous pouvez essayer par Install package ça peut marcher ou extract .....
                  Perso install package sur les scripts récalcitrant ça n'a pas marché, Extract package m'a permis d'en installer 1 qui ne voulait pas et pour les durs de durs, faite Explore Package vous ouvrez à ce moment une nouvelle fenêtre ou vous verrez complètement a droite un icône intitulé " Extrac All " cliquer dessus et indiquer le chemin, si vous n'avez qu'un seul X3 installer sur votre disque dur ça devrait être c:/Program Files/DeepSilver/X3 Réunion et là vous installer le plus têtu des scripts j'espère avoir été assez précis et que que cette soluce vous évitera des grincements de dents, en tout cas je suis à votre dispos en cas de Blèmes.
                  @+ et bon jeux

                  Commentaire


                    #10
                    Merci pour le retour Chris !!:-)
                    Je n'avais essayer le "Xscript Installer" de cette façon !! il faudra que j'essaye ..merci le principal étant que tout fonctionne normalement!
                    Rendez-vous dans Nouveaux Horizons et son univers 8)!!
                    Cpt-Killer NH's BREIZH TEAM ..

                    Commentaire


                      #11
                      J'ai également un problème qui semble lié à ce script.

                      Au début du mois de mai j'avais installé ces scripts :

                      - PiloteIA 3.55
                      - Advanced Tractor Beam 1.02
                      - Factory Complex Constructor 3.21 (version traduite en français avec installeur automatique que l'on peut télécharger ici : http://www.3enfamille.net/page_scrip...argements.html

                      Mais depuis je me suis retrouvé avec un méchant problème de sauvegarde corrompue...

                      Pour installer PiloteIA j'avais d'abord choisi les fichiers fournis en .zip mais on dirait que j'ai peut-être mal fait quelque chose.

                      Cet après-midi j'ai tenté de régler le problème en réinstallant entièrement X3, puis en remettant les scripts, et cette fois j'ai utilisé la version 3.56 de PiloteIA avec le fichier .spk que l'on installe avec X Plugin Manager, sans grand changement hélas.

                      Le problème exact que je rencontre est que les sauvegardes que j'ai réalisées après l'installation de ces trois scripts font planter le jeu une fois le chargement de la sauvegarde terminé. C'est assez crispant, car la commande reinit script cache ne parvient pas à résoudre le problème. J'ai beau la lancer juste avant de sauvegarder ça ne change rien ; même si la sauvegarde a l'air correcte quand je la charge en ayant une partie en cours (une précédente sauvegarde datant d'avant l'installation des scripts), elle fait planter le jeu si je la charge juste après avoir démarré le jeu
                      .

                      Etant donné que le script FCC est le seul des trois que je n'ai pas installé via XPlugin Manager, je pense qu'il est possible qu'il soit à l'origine de mes problèmes.

                      Commentaire


                        #12
                        Hello Volcanosf
                        as-tu essayé sans ce script pour être sûr que cela vient de lui ?

                        Et sinon, essaie de l'installer 'à la main' à partir de laversion .rar... sans utiliser le spk donc, juste en recopiant le contenu des dossiers 't' et 'scripts' dans ton répertoire de jeu....
                        aille ame a pis
                        sigpic

                        Commentaire


                          #13
                          c'est curieux, j'installe ce script systématiquement, même si je n'ai jamais le temps de l'utilisé.
                          je n'ai jamais eu de soucis avec le .SPK et pourtant j'en fait des instals et ré-instals.

                          idem avec les 2 autres scripts d'ailleurs.
                          il doit il y avoir quelque chose dans tes sauvegardes qui manque actuellement dans ton instal et qui plante le jeu:?
                          SIKY NH's BREIZH TEAM

                          Commentaire


                            #14
                            Pour être plus précis, je n'ai pas utilisé le fichier .spk et Xplugin Manager pour installer FCC, mais l'installeur .exe de la version traduite en français par Dusty.

                            Mais bon, je n'ai pas de certitude absolue que c'est bien lui qui cause mon problème. :?

                            Commentaire


                              #15
                              Bon eh bien, je viens de faire des tests en désactivant les scripts un par un et en rechargeant une sauvegarde "incriminée" après chaque désactivation.

                              En fin de compte je me trompais. Après désactivation d'Advanced Tractor Beam 1.02 le problème subsistait, mais il a disparu après que j'aie désactivé PiloteIA 3.56 . FCC n'y était donc pour rien dans mes problèmes.

                              Par précaution je vais tout de même me faire une réinstallation complète de X3 avec suppression de tous les fichiers du répertoire source du jeu après la désinstallation et utiliser la version .spk de FCC.

                              Par contre j'ai vu que, sur le forum d'Egosoft, Cassin a rapporté un problème lié à la version de FCC avec autoinstalleur (http://forum.egosoft.com/viewtopic.p...471934#2471934) à moins que le problème dont il parle n'ait déjà été résolu ?

                              Commentaire

                              Chargement...
                              X